From: Florian Eckert <fe@dev.tdt.de>
Date: Tue, 2 Jul 2019 10:04:58 +0000 (+0200)
Subject: kernel: add pcengines-apu2 module description
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=f3c5c09e5ad6671519c6a3b29f9c6adb7fff66cb;p=openwrt%2Fstaging%2Fldir.git

kernel: add pcengines-apu2 module description

Add a module description for the new pcengnies-apu2 device driver.
This driver supports the front button and LEDs on the PC Engines
APUv2/APUv3 boards.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
---

diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index c8722938d3..61ab400dc9 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -34,3 +34,20 @@ define KernelPackage/sp5100-tco/description
 endef
 
 $(eval $(call KernelPackage,sp5100-tco))
+
+
+define KernelPackage/pcengines-apuv2
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=PC Engines APUv2/3 front button and LEDs driver
+  DEPENDS:=@TARGET_x86 +kmod-gpio-amd-fch +kmod-leds-gpio
+  KCONFIG:=CONFIG_PCENGINES_APU2
+  FILES:=$(LINUX_DIR)/drivers/platform/x86/pcengines-apuv2.ko
+  AUTOLOAD:=$(call AutoLoad,60,pcengines-apuv2)
+endef
+
+define KernelPackage/pcengines-apuv2/description
+  This driver provides support for the front button and LEDs on
+  PC Engines APUv2/APUv3 board.
+endef
+
+$(eval $(call KernelPackage,pcengines-apuv2))