From: Gregory L. Dietsche <Gregory.Dietsche@cuw.edu>
Date: Sun, 7 Jun 2020 04:30:23 +0000 (-0500)
Subject: x86: Support Intel 10 Gigabit Ethernet Cards
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=f3cb1636abeaba5a753d70592d05541ad929daeb;p=openwrt%2Fstaging%2Fldir.git

x86: Support Intel 10 Gigabit Ethernet Cards

Support Intel 10 Gigabit Ethernet Cards in x86/64 images by default.
This ensures that systems with cards such as the Intel x520 will work properly.

Signed-off-by: Gregory L. Dietsche <Gregory.Dietsche@cuw.edu>
---

diff --git a/target/linux/x86/image/64.mk b/target/linux/x86/image/64.mk
index 61e6d408d7..745b307585 100644
--- a/target/linux/x86/image/64.mk
+++ b/target/linux/x86/image/64.mk
@@ -1,7 +1,7 @@
 define Device/generic
   DEVICE_TITLE := Generic x86/64
   DEVICE_PACKAGES += kmod-bnx2 kmod-e1000e kmod-e1000 kmod-forcedeth kmod-igb \
-	kmod-r8169
+	kmod-ixgbe kmod-r8169
   GRUB2_VARIANT := generic
 endef
 TARGET_DEVICES += generic