From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 17 Dec 2012 15:11:34 +0000 (+0000)
Subject: tools: add a symlink for gnu awk to fix kernel build errors on some platforms
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=f403e2dcca7b2ee86ef84c3bf673e521495b1534;p=openwrt%2Fstaging%2Fnbd.git

tools: add a symlink for gnu awk to fix kernel build errors on some platforms

SVN-Revision: 34736
---

diff --git a/tools/Makefile b/tools/Makefile
index 9a0e148234..802d6c9aee 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -128,8 +128,9 @@ $(eval $(call PrepareCommand,md5sum,gmd5sum md5sum $(SCRIPT_DIR)/md5sum))
 $(eval $(call PrepareCommand,cp,gcp cp))
 $(eval $(call PrepareCommand,seq,gseq seq))
 $(eval $(call PrepareCommand,python,python2 python))
+$(eval $(call PrepareCommand,awk,gawk awk))
 
-$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp stat seq python)
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp stat seq python awk)
 $(curdir)//prepare = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(curdir)/cmddeps)
 $(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(curdir)/cmddeps)