From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sat, 2 Apr 2011 19:31:21 +0000 (+0000)
Subject: kernel: remove double definition of depends in crypto-mv-cesa and make it look like... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=f4aef6d5534e65a7c1bce7a118168ff5e85f0f75;p=openwrt%2Fstaging%2Faparcar.git

kernel: remove double definition of depends in crypto-mv-cesa and make it look like the other entries.

Thank you Maarten

SVN-Revision: 26413
---

diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 685305066c..467db8ee23 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -427,13 +427,12 @@ endef
 $(eval $(call KernelPackage,crypto-xts))
 
 define KernelPackage/crypto-mv-cesa
-   TITLE:=Marvell crypto engine
-   DEPENDS:=+kmod-crypto-manager
-   KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
-   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
-   AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
-   SUBMENU:=Cryptographic API modules
-   DEPENDS:=kmod-crypto-core @TARGET_kirkwood||TARGET_orion
+  TITLE:=Marvell crypto engine
+  DEPENDS:=+kmod-crypto-manager @TARGET_kirkwood||TARGET_orion
+  KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
+  FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
+  AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-mv-cesa))