From: Petr Štetiar <ynezz@true.cz>
Date: Mon, 20 May 2019 14:47:23 +0000 (+0200)
Subject: build: add urandom-seed and urngd to default packages set
X-Git-Tag: v21.02.0-rc1~5849
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=f5387b754f98f85bf4a1c8c392a965bdbcb96db6;p=openwrt%2Fopenwrt.git

build: add urandom-seed and urngd to default packages set

urandom-seed content was split from base-files into separate package so
in order to preserve the current functionality and to provide some
fallback mechanism in case jent-rng initialization fails in urngd we
need to add it back.

urngd is OpenWrt's micro non-physical true random number generator based
on timing jitter.

Tested-by: Lucian Cristian <lucian.cristian@gmail.com>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
---

diff --git a/include/target.mk b/include/target.mk
index 4f3bd43e6c..a813ba2d2d 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -13,7 +13,7 @@ __target_inc=1
 DEVICE_TYPE?=router
 
 # Default packages - the really basic set
-DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg netifd fstools uclient-fetch logd
+DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg netifd fstools uclient-fetch logd urandom-seed urngd
 # For nas targets
 DEFAULT_PACKAGES.nas:=block-mount fdisk lsblk mdadm
 # For router targets