From: Felix Fietkau <nbd@openwrt.org>
Date: Thu, 5 Nov 2009 21:25:31 +0000 (+0000)
Subject: uboot-ifxmips: fix compile errors with the cs toolchain due to non-PIC code
X-Git-Tag: reboot~21948
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=f70c8b37e4efff5127f489da3f160fa3585848b1;p=openwrt%2Fstaging%2Fblogic.git

uboot-ifxmips: fix compile errors with the cs toolchain due to non-PIC code

SVN-Revision: 18321
---

diff --git a/package/uboot-ifxmips/patches/110-compile_fix.patch b/package/uboot-ifxmips/patches/110-compile_fix.patch
new file mode 100644
index 000000000000..34d0ac6e5308
--- /dev/null
+++ b/package/uboot-ifxmips/patches/110-compile_fix.patch
@@ -0,0 +1,25 @@
+--- a/cpu/mips/Makefile
++++ b/cpu/mips/Makefile
+@@ -36,6 +36,9 @@ START	:= $(addprefix $(obj),$(START))
+ 
+ all:	$(obj).depend $(START) $(LIB)
+ 
++start.o: start.S
++	$(CC) $(AFLAGS) -fPIC -c -o $@ $<
++
+ $(LIB):	$(OBJS)
+ 	$(AR) $(ARFLAGS) $@ $(OBJS)
+ 
+--- a/Makefile
++++ b/Makefile
+@@ -185,8 +185,8 @@ include $(TOPDIR)/config.mk
+ OBJS  = cpu/$(CPU)/start.o
+ OBJS_BOOTSTRAP  = cpu/$(CPU)/start_bootstrap.o
+ 
+-cpu/$(CPU)/start_bootstrap.S: cpu/$(CPU)/start.S
+-	ln -s start.S cpu/$(CPU)/start_bootstrap.S
++cpu/$(CPU)/start_bootstrap.o: cpu/$(CPU)/start.S
++	$(CC) $(AFLAGS) -fPIC -DCFG_BOOTSTRAP_CODE -c -o $@ $<
+ 
+ ifeq ($(CPU),i386)
+ OBJS += cpu/$(CPU)/start16.o