From: Imre Kaloz <kaloz@openwrt.org>
Date: Sun, 15 Nov 2009 20:25:29 +0000 (+0000)
Subject: make the lzma version kernel version dependent, and only build the one we do need
X-Git-Tag: reboot~21881
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=f87c3cbb3adcb45c6d0b414361107e866591aee7;p=openwrt%2Fstaging%2Fxback.git

make the lzma version kernel version dependent, and only build the one we do need

SVN-Revision: 18426
---

diff --git a/tools/Makefile b/tools/Makefile
index b7c7f43db6..e3e26f3c4f 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -14,11 +14,15 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
 endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
-tools-y += sstrip ipkg-utils genext2fs squashfs squashfs4 mtd-utils lzma-old mkimage
+tools-y += sstrip ipkg-utils genext2fs mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2
+ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_21)$(CONFIG_LINUX_2_6_25)$(CONFIG_LINUX_2_6_28),)
+tools-y += squashfs lzma-old 
+else
+tools-y += squashfs4 lzma
+endif
 
 tools-$(CONFIG_CCACHE) += ccache
-tools-dep += lzma
 
 ifdef CONFIG_GCC_USE_GRAPHITE
   tools-y += ppl cloog
diff --git a/tools/lzma/Makefile b/tools/lzma/Makefile
index bebfbafd57..b39c8627ec 100644
--- a/tools/lzma/Makefile
+++ b/tools/lzma/Makefile
@@ -27,6 +27,7 @@ endef
 
 define Host/Install
 	$(INSTALL_DIR) $(STAGING_DIR_HOST)/lib $(STAGING_DIR_HOST)/include $(STAGING_DIR_HOST)/bin
+	$(INSTALL_BIN) $(HOST_BUILD_DIR)/CPP/7zip/Compress/LZMA_Alone/lzma_alone $(STAGING_DIR_HOST)/bin/lzma
 	$(CP) $(HOST_BUILD_DIR)/C/*.h $(STAGING_DIR_HOST)/include/
 	$(CP) $(UTIL_DIR)/liblzma.a $(STAGING_DIR_HOST)/lib/
 endef