From: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Date: Wed, 13 Sep 2017 18:51:13 +0000 (-0700)
Subject: at91: Renaming subtarget sama5d3 to sama5
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=f8a5ac1a8835b9c826286469379a143ff9e532d5;p=openwrt%2Fstaging%2Flynxis.git

at91: Renaming subtarget sama5d3 to sama5

Renaming at91 subtarget sama5d3 to sama5 and using at91-sama5d3_xplained
as a target device in sama5 subtarget.This will enable to add other
sama5d2 & sama5d4 target devices in sama5 subtraget.This will avoid
code duplication when sama5d2 & sama5d4 added as different subtarget.

Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
---

diff --git a/target/linux/at91/Makefile b/target/linux/at91/Makefile
index a3e0be7c8a..948419a7aa 100644
--- a/target/linux/at91/Makefile
+++ b/target/linux/at91/Makefile
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=at91
 MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
-BOARDNAME:=Atmel AT91
+BOARDNAME:=Microchip (Atmel AT91)
 FEATURES:=squashfs targz ext2 usb usbgadget ubifs
-SUBTARGETS:=legacy sama5d3
+SUBTARGETS:=sama5 legacy
 
 KERNEL_PATCHVER:=4.4
 
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index d1ae61484a..6e2b6b6101 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -13,8 +13,9 @@ ifeq ($(SUBTARGET),legacy)
 include ./legacy.mk
 UBIFS_OPTS := -m 2048 -e 126KiB -c 2048
 endif
-ifeq ($(SUBTARGET),sama5d3)
-include ./sama5d3.mk
+
+ifeq ($(SUBTARGET),sama5)
+include ./sama5.mk
 UBIFS_OPTS := -m 2048 -e 124KiB -c 2048
 endif
 
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
new file mode 100644
index 0000000000..11d8538dff
--- /dev/null
+++ b/target/linux/at91/image/sama5.mk
@@ -0,0 +1,7 @@
+define Device/at91-sama5d3_xplained
+  $(Device/evaluation-dtb)
+  DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
+  KERNEL_SIZE := 6144k
+  SUBPAGESIZE := 2048
+endef
+TARGET_DEVICES += at91-sama5d3_xplained
diff --git a/target/linux/at91/image/sama5d3.mk b/target/linux/at91/image/sama5d3.mk
deleted file mode 100644
index fb02ee1bc0..0000000000
--- a/target/linux/at91/image/sama5d3.mk
+++ /dev/null
@@ -1,8 +0,0 @@
-define Device/at91-sama5d3_xplained
-  $(Device/evaluation-dtb)
-  DEVICE_TITLE := Atmel AT91SAMA5D3XPLAINED
-  KERNEL_SIZE := 6144k
-  SUBPAGESIZE := 2048
-endef
-TARGET_DEVICES += at91-sama5d3_xplained
-
diff --git a/target/linux/at91/sama5/config-default b/target/linux/at91/sama5/config-default
new file mode 100644
index 0000000000..660e27e8aa
--- /dev/null
+++ b/target/linux/at91/sama5/config-default
@@ -0,0 +1,20 @@
+# CONFIG_ARCH_MULTI_V4_V5 is not set
+# CONFIG_ARCH_MULTI_V5 is not set
+CONFIG_ARCH_MULTI_V7=y
+# CONFIG_ARM_LPAE is not set
+# CONFIG_ARM_THUMBEE is not set
+# CONFIG_CPU_ICACHE_DISABLE is not set
+# CONFIG_CPU_BPREDICT_DISABLE is not set
+CONFIG_SOC_SAMA5=y
+# CONFIG_SOC_SAM_V4_V5 is not set
+CONFIG_SOC_SAM_V7=y
+CONFIG_SOC_SAMA5D2=y
+CONFIG_SOC_SAMA5D3=y
+CONFIG_SOC_SAMA5D4=y
+CONFIG_MACH_SAMA5_DT=y
+CONFIG_PL310_ERRATA_588369=y
+CONFIG_PL310_ERRATA_727915=y
+CONFIG_PL310_ERRATA_753970=y
+CONFIG_PL310_ERRATA_769419=y
+# CONFIG_SWP_EMULATE is not set
+# CONFIG_THUMB2_KERNEL is not set
diff --git a/target/linux/at91/sama5/target.mk b/target/linux/at91/sama5/target.mk
new file mode 100644
index 0000000000..7ccf30b386
--- /dev/null
+++ b/target/linux/at91/sama5/target.mk
@@ -0,0 +1,9 @@
+BOARDNAME:=SAMA5 Xplained boards(Cortex-A5)
+CPU_TYPE:=cortex-a5
+
+DEFAULT_PACKAGES += kmod-usb2
+
+define Target/Description
+	Build generic firmware for Microchip(Atmel AT91) SAMA5 MPU's
+	using the ARMv7 instruction set.
+endef
diff --git a/target/linux/at91/sama5d3/config-default b/target/linux/at91/sama5d3/config-default
deleted file mode 100644
index 660e27e8aa..0000000000
--- a/target/linux/at91/sama5d3/config-default
+++ /dev/null
@@ -1,20 +0,0 @@
-# CONFIG_ARCH_MULTI_V4_V5 is not set
-# CONFIG_ARCH_MULTI_V5 is not set
-CONFIG_ARCH_MULTI_V7=y
-# CONFIG_ARM_LPAE is not set
-# CONFIG_ARM_THUMBEE is not set
-# CONFIG_CPU_ICACHE_DISABLE is not set
-# CONFIG_CPU_BPREDICT_DISABLE is not set
-CONFIG_SOC_SAMA5=y
-# CONFIG_SOC_SAM_V4_V5 is not set
-CONFIG_SOC_SAM_V7=y
-CONFIG_SOC_SAMA5D2=y
-CONFIG_SOC_SAMA5D3=y
-CONFIG_SOC_SAMA5D4=y
-CONFIG_MACH_SAMA5_DT=y
-CONFIG_PL310_ERRATA_588369=y
-CONFIG_PL310_ERRATA_727915=y
-CONFIG_PL310_ERRATA_753970=y
-CONFIG_PL310_ERRATA_769419=y
-# CONFIG_SWP_EMULATE is not set
-# CONFIG_THUMB2_KERNEL is not set
diff --git a/target/linux/at91/sama5d3/target.mk b/target/linux/at91/sama5d3/target.mk
deleted file mode 100644
index 0319f4bf0d..0000000000
--- a/target/linux/at91/sama5d3/target.mk
+++ /dev/null
@@ -1,9 +0,0 @@
-BOARDNAME:=SAMA5D3 (Cortex-A5)
-CPU_TYPE:=cortex-a5
-
-DEFAULT_PACKAGES += kmod-usb2
-
-define Target/Description
-	Build generic firmware for SAMA5D3 AT91 platforms
-	using the ARMv7 instruction set.
-endef