From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 26 Aug 2013 17:31:27 +0000 (+0000)
Subject: mklibs: Fix mklibs usage when *.so files reside in subdirs
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=f91d09cabb21d8f6011903174e2bafa3dc7f4f39;p=openwrt%2Fstaging%2F981213.git

mklibs: Fix mklibs usage when *.so files reside in subdirs

Currently package/Makefile only passes /lib /usr/lib and /usr/lib/ebtables
to mklibs. However, other libs can also reside in different subdirectories
(in my case /usr/lib/ipsec). Hence, create the list of library directories
dynamically.

Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com>

SVN-Revision: 37841
---

diff --git a/package/Makefile b/package/Makefile
index f8002348b1..00ac773499 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -34,20 +34,18 @@ ifdef CONFIG_USE_MKLIBS
 	# find all loadable objects that are not regular libraries and add them to the list as well
 	find $(STAGING_DIR_ROOT) -type f -name \*.so\* -exec \
 		file -r -N -F '' {} + | \
-		awk ' /shared object/ { print $$1 }' >> $(TMP_DIR)/mklibs-progs
+		awk ' /shared object/ { print $$1 }' > $(TMP_DIR)/mklibs-libs
 	mkdir -p $(TMP_DIR)/mklibs-out
 	$(STAGING_DIR_HOST)/bin/mklibs -D \
 		-d $(TMP_DIR)/mklibs-out \
 		--sysroot $(STAGING_DIR_ROOT) \
-		-L /lib \
-		-L /usr/lib \
-		-L /usr/lib/ebtables \
+		`cat $(TMP_DIR)/mklibs-libs | sed 's:/*[^/]\+/*$$::' | uniq | sed 's:^$(STAGING_DIR_ROOT):-L :'` \
 		--ldlib $(patsubst $(STAGING_DIR_ROOT)/%,/%,$(firstword $(wildcard \
 			$(foreach name,ld-uClibc.so.* ld-linux.so.* ld-*.so, \
 			  $(STAGING_DIR_ROOT)/lib/$(name) \
 			)))) \
 		--target $(REAL_GNU_TARGET_NAME) \
-		`cat $(TMP_DIR)/mklibs-progs` 2>&1
+		`cat $(TMP_DIR)/mklibs-progs $(TMP_DIR)/mklibs-libs` 2>&1
 	$(RSTRIP) $(TMP_DIR)/mklibs-out
 	for lib in `ls $(TMP_DIR)/mklibs-out/*.so.* 2>/dev/null`; do \
 		LIB="$${lib##*/}"; \