From: John Crispin <john@openwrt.org>
Date: Mon, 2 Jun 2014 12:45:05 +0000 (+0000)
Subject: kernel: Fix xen domU kmod-xen-kbd package
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=f91dd34ee9a3d412c9dc7ff523de56a4f5a7f66a;p=openwrt%2Fstaging%2Fynezz.git

kernel: Fix xen domU kmod-xen-kbd package

modified version of http://patchwork.openwrt.org/patch/5526/

Signed-off-by: John Crispin <blogic@openwrt.org>

SVN-Revision: 40941
---

diff --git a/package/kernel/linux/modules/virtual.mk b/package/kernel/linux/modules/virtual.mk
index e1bbe3f439..3a1fe006fa 100644
--- a/package/kernel/linux/modules/virtual.mk
+++ b/package/kernel/linux/modules/virtual.mk
@@ -142,8 +142,9 @@ $(eval $(call KernelPackage,xen-fbdev))
 define KernelPackage/xen-kbddev
   SUBMENU:=$(VIRTUAL_MENU)
   TITLE:=Xen virtual keyboard and mouse
-  DEPENDS:=@TARGET_x86_xen_domu
-  KCONFIG:=CONFIG_XEN_KBDDEV_FRONTEND
+  DEPENDS:=@TARGET_x86_xen_domu +kmod-input-core
+  KCONFIG:=CONFIG_INPUT_MISC=y \
+	CONFIG_INPUT_XEN_KBDDEV_FRONTEND
   FILES:=$(LINUX_DIR)/drivers/input/xen-kbdfront.ko
   AUTOLOAD:=$(call AutoLoad,08,xen-kbdfront)
 endef