From: Lech Perczak <lech.perczak@gmail.com>
Date: Thu, 28 Apr 2022 21:31:58 +0000 (+0200)
Subject: imx: create sdcard image recipe with raw U-Boot
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=f987887e14702ef0fe63b1721f498946669e3b79;p=openwrt%2Fstaging%2Fjogo.git

imx: create sdcard image recipe with raw U-Boot

Most i.MX boards booting off eMMC or SD cards use raw U-Boot located at
69 kB offset from beginning of the device - create a recipe for such
image.

Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
---

diff --git a/target/linux/imx/image/common.mk b/target/linux/imx/image/common.mk
index 8a9b260584..3b528a02b1 100644
--- a/target/linux/imx/image/common.mk
+++ b/target/linux/imx/image/common.mk
@@ -49,3 +49,13 @@ define Build/imx-sdcard
 
 	$(Build/imx-combined-image-clean)
 endef
+
+define Build/imx-sdcard-raw-uboot
+	$(Build/imx-combined-image-prepare)
+
+	$(Build/imx-combined-image)
+	dd if=$(STAGING_DIR_IMAGE)/$(UBOOT)-SPL of=$@ bs=1024 seek=1 conv=notrunc
+	dd if=$(STAGING_DIR_IMAGE)/$(UBOOT)-u-boot-dtb.img of=$@ bs=1024 seek=69 conv=notrunc
+
+	$(Build/imx-combined-image-clean)
+endef