From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sun, 9 Aug 2015 17:18:10 +0000 (+0000)
Subject: kernel: crypto: fix depends in kmod-crypto-hmac
X-Git-Tag: reboot~2314
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=f9ebd0b1a47ba4f47a9f710d20ffb9aa52ffca85;p=openwrt%2Fopenwrt.git

kernel: crypto: fix depends in kmod-crypto-hmac

This module had two depends lines.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>

SVN-Revision: 46576
---

diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index d530b1471a..2e245e37a9 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -380,10 +380,9 @@ $(eval $(call KernelPackage,crypto-ecb))
 
 define KernelPackage/crypto-hmac
   TITLE:=HMAC digest CryptoAPI module
-  DEPENDS:=+kmod-crypto-hash
+  DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager
   KCONFIG:=CONFIG_CRYPTO_HMAC
   FILES:=$(LINUX_DIR)/crypto/hmac.ko
-  DEPENDS:=+kmod-crypto-manager
   AUTOLOAD:=$(call AutoLoad,09,hmac)
   $(call AddDepends/crypto)
 endef