From: Josua Mayer <josua.mayer97@gmail.com>
Date: Tue, 16 Aug 2016 14:02:43 +0000 (+0200)
Subject: mvebu: add fpu to features
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=fa0c45c397c722eb6b20a055fdf53b7488b2d8e8;p=openwrt%2Fstaging%2Fnbd.git

mvebu: add fpu to features

This triggers HAS_FPU=y, and unsets CONFIG_SOFT_FLOAT.
Considering all mvebu boards have an fpu, this is the desirable behaviour.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
---

diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
index bda69f64c7..e319a8f822 100644
--- a/target/linux/mvebu/Makefile
+++ b/target/linux/mvebu/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=mvebu
 BOARDNAME:=Marvell Armada 37x/38x/XP
-FEATURES:=usb pci pcie gpio nand squashfs
+FEATURES:=fpu usb pci pcie gpio nand squashfs
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>