From: Jo-Philipp Wich <jow@openwrt.org>
Date: Sun, 18 Mar 2012 18:49:38 +0000 (+0000)
Subject: [package] kernel: add kmod-usb-serial-qualcomm (#8283)
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=fa73dd4622794a8bd4869d57fe1f837f7588c76d;p=openwrt%2Fsvn-archive%2Farchive.git

[package] kernel: add kmod-usb-serial-qualcomm (#8283)


SVN-Revision: 30979
---

diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index d454947d93..e4f099510c 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -606,6 +606,20 @@ endef
 $(eval $(call KernelPackage,usb-serial-option))
 
 
+define KernelPackage/usb-serial-qualcomm
+  TITLE:=Support for Qualcomm USB serial
+  KCONFIG:=CONFIG_USB_SERIAL_QUALCOMM
+  FILES:=$(LINUX_DIR)/drivers/usb/serial/qcserial.ko
+  AUTOLOAD:=$(call AutoLoad,65,qcserial)
+endef
+
+define KernelPackage/usb-serial-qualcomm/description
+ Kernel support for Qualcomm USB Serial devices (Gobi)
+endef
+
+$(eval $(call KernelPackage,usb-serial-qualcomm))
+
+
 define KernelPackage/usb-storage
   TITLE:=USB Storage support
   DEPENDS:= +kmod-scsi-core