From: Nicolas Thill <nico@openwrt.org>
Date: Sat, 3 Apr 2010 21:38:17 +0000 (+0000)
Subject: opkg: add upstream patch fixing the order packages are configured (closes: #7057... 
X-Git-Tag: reboot~20326
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=fc72a828f59b59308dfc6e6fb4c3482e53aadf7f;p=openwrt%2Fstaging%2Fchunkeey.git

opkg: add upstream patch fixing the order packages are configured (closes: #7057, #7058), bump release number

SVN-Revision: 20686
---

diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index 6894ae7cb4..81f7b4a4a0 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=opkg
 PKG_REV:=513
 PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=svn
 PKG_SOURCE_VERSION:=$(PKG_REV)
diff --git a/package/opkg/patches/000-upstream-fix_configure_order.patch b/package/opkg/patches/000-upstream-fix_configure_order.patch
new file mode 100644
index 0000000000..dcd1b547c2
--- /dev/null
+++ b/package/opkg/patches/000-upstream-fix_configure_order.patch
@@ -0,0 +1,15 @@
+http://code.google.com/p/opkg/source/detail?r=521
+
+--- a/libopkg/opkg_cmd.c
++++ b/libopkg/opkg_cmd.c
+@@ -390,8 +390,8 @@ opkg_configure_packages(char *pkg_name)
+ 	     goto error;
+      }
+     
+-     for(i = 0; i < all->len; i++) {
+-	  pkg = all->pkgs[i];
++     for(i = 0; i < ordered->len; i++) {
++	  pkg = ordered->pkgs[i];
+ 
+ 	  if (pkg_name && fnmatch(pkg_name, pkg->name, 0)) 
+ 	       continue;