From: Felix Fietkau <nbd@openwrt.org>
Date: Sun, 13 Mar 2011 18:38:43 +0000 (+0000)
Subject: download.mk: properly quote download urls
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=fd0deca65d9d3d5fb074ea594970c7f1a5b19341;p=openwrt%2Fstaging%2Faparcar.git

download.mk: properly quote download urls

SVN-Revision: 26129
---

diff --git a/include/download.mk b/include/download.mk
index d1b3fc8f87..fd197ea216 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -41,7 +41,7 @@ define DownloadMethod/unknown
 endef
 
 define DownloadMethod/default
-	$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MD5SUM)" $(URL)
+	$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MD5SUM)" $(foreach url,$(URL),"$(url)")
 endef
 
 define wrap_mirror