From: Felix Fietkau <nbd@nbd.name>
Date: Thu, 29 Mar 2018 14:12:43 +0000 (+0200)
Subject: build: filter out kmod-ipt-offload from the default selection on targets that do... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=fd588dbf6becc9be2fb34f132f132b3e9a985bfb;p=openwrt%2Fstaging%2Fnbd.git

build: filter out kmod-ipt-offload from the default selection on targets that do not support it

Signed-off-by: Felix Fietkau <nbd@nbd.name>
---

diff --git a/include/target.mk b/include/target.mk
index d4950e5b2b..8d5ae1e1d3 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -51,6 +51,10 @@ else
   endif
 endif
 
+ifneq ($(filter 3.18 4.4 4.9,$(KERNEL_PATCHVER)),)
+  DEFAULT_PACKAGES.router:=$(filter-out kmod-ipt-offload,$(DEFAULT_PACKAGES.router))
+endif
+
 # Add device specific packages (here below to allow device type set from subtarget)
 DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))