From: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Date: Wed, 13 Sep 2017 18:51:16 +0000 (-0700)
Subject: at91: Add SAMA5D2 device
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=fdaaa923ddb9ae18760da11df7d473e7bb950824;p=openwrt%2Fstaging%2Fnbd.git

at91: Add SAMA5D2 device

Add support for SAMA5D2 with target device as at91-sama5d2_xplained
in SAMA5 subtarget and build images for SAMA5D2 Xplained board.

Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
---

diff --git a/target/linux/at91/base-files/lib/at91.sh b/target/linux/at91/base-files/lib/at91.sh
index 0fa2ee3251..84beecd9d2 100755
--- a/target/linux/at91/base-files/lib/at91.sh
+++ b/target/linux/at91/base-files/lib/at91.sh
@@ -43,6 +43,9 @@ at91_board_detect() {
 	*"SAMA5D3 Xplained")
 		name="sama5d3_xplained"
 		;;
+	*"SAMA5D2 Xplained")
+		name="sama5d2_xplained"
+		;;
 	*"CalAmp LMU5000")
 		name="lmu5000"
 		;;
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index 11d8538dff..1faeb4baa9 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -5,3 +5,11 @@ define Device/at91-sama5d3_xplained
   SUBPAGESIZE := 2048
 endef
 TARGET_DEVICES += at91-sama5d3_xplained
+
+define Device/at91-sama5d2_xplained
+  $(Device/evaluation-dtb)
+  DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
+  KERNEL_SIZE := 6144k
+  SUBPAGESIZE := 2048
+endef
+TARGET_DEVICES += at91-sama5d2_xplained