From: Jo-Philipp Wich <jow@openwrt.org>
Date: Sat, 31 Jan 2015 13:55:51 +0000 (+0000)
Subject: linux: convert CompareKernelPatchVer to version tagged symbols
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=fdb0d6d860240d51470a520c1e0437168757f81e;p=openwrt%2Fsvn-archive%2Fopenwrt.git

linux: convert CompareKernelPatchVer to version tagged symbols

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

SVN-Revision: 44229
---

diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 2f1d33f4a4..4df2d7393a 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -329,13 +329,10 @@ define KernelPackage/crypto-crc32c
   TITLE:=CRC32c CRC module
   DEPENDS:=+kmod-crypto-hash
   KCONFIG:=CONFIG_CRYPTO_CRC32C
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.15.0)),1)
-  FILES:=$(LINUX_DIR)/crypto/crc32c_generic.ko
-  AUTOLOAD:=$(call AutoLoad,04,crc32c_generic,1)
-else
-  FILES:=$(LINUX_DIR)/crypto/crc32c.ko
-  AUTOLOAD:=$(call AutoLoad,04,crc32c,1)
-endif
+  FILES:= \
+	$(LINUX_DIR)/crypto/crc32c.ko@lt3.15 \
+	$(LINUX_DIR)/crypto/crc32c_generic.ko@ge3.15
+  AUTOLOAD:=$(call AutoLoad,04,crc32c@lt3.15 crc32c_generic@ge3.15,1)
   $(call AddDepends/crypto)
 endef
 
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index b30d116098..69fce51e2f 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -316,20 +316,13 @@ define KernelPackage/fs-nfs-common
   TITLE:=Common NFS filesystem modules
   KCONFIG:= \
 	CONFIG_LOCKD \
-	CONFIG_SUNRPC
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.18.0)),1)
-  KCONFIG+=CONFIG_GRACE_PERIOD
+	CONFIG_SUNRPC \
+	CONFIG_GRACE_PERIOD@ge3.18
   FILES:= \
-	$(LINUX_DIR)/fs/nfs_common/grace.ko \
 	$(LINUX_DIR)/fs/lockd/lockd.ko \
-	$(LINUX_DIR)/net/sunrpc/sunrpc.ko
-  AUTOLOAD:=$(call AutoLoad,30,grace sunrpc lockd)
-else
-  FILES:= \
-	$(LINUX_DIR)/fs/lockd/lockd.ko \
-	$(LINUX_DIR)/net/sunrpc/sunrpc.ko
-  AUTOLOAD:=$(call AutoLoad,30,sunrpc lockd)
-endif
+	$(LINUX_DIR)/net/sunrpc/sunrpc.ko \
+	$(LINUX_DIR)/fs/nfs_common/grace.ko@ge3.18
+  AUTOLOAD:=$(call AutoLoad,30,grace@ge3.18 sunrpc lockd)
 endef
 
 $(eval $(call KernelPackage,fs-nfs-common))
diff --git a/package/kernel/linux/modules/i2c.mk b/package/kernel/linux/modules/i2c.mk
index 8fed494e4f..d4effee13d 100644
--- a/package/kernel/linux/modules/i2c.mk
+++ b/package/kernel/linux/modules/i2c.mk
@@ -24,10 +24,8 @@ I2C_CORE_MODULES:= \
   CONFIG_I2C:drivers/i2c/i2c-core \
   CONFIG_I2C_CHARDEV:drivers/i2c/i2c-dev
 
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.12.0)),1)
-  ifeq ($(CONFIG_OF),y)
-    I2C_CORE_MODULES+=CONFIG_OF_I2C:drivers/of/of_i2c
-  endif
+ifeq ($(CONFIG_OF),y)
+  I2C_CORE_MODULES+=CONFIG_OF_I2C:drivers/of/of_i2c@lt3.12
 endif
 
 define KernelPackage/i2c-core
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index fed20f5a6f..b5dc92f39b 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -114,11 +114,9 @@ define KernelPackage/et131x
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Agere ET131x Gigabit Ethernet driver
   URL:=http://sourceforge.net/projects/et131x
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.18.0)),1)
-  FILES:=$(LINUX_DIR)/drivers/net/ethernet/agere/et131x.$(LINUX_KMOD_SUFFIX)
-else
-  FILES:=$(LINUX_DIR)/drivers/staging/et131x/et131x.$(LINUX_KMOD_SUFFIX)
-endif
+  FILES:= \
+	$(LINUX_DIR)/drivers/staging/et131x/et131x.ko@lt3.18 \
+	$(LINUX_DIR)/drivers/net/ethernet/agere/et131x.ko@ge3.18
   KCONFIG:= \
 	CONFIG_ET131X \
 	CONFIG_ET131X_DEBUG=n
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index a69d817ed3..2800387a0a 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -261,11 +261,9 @@ define KernelPackage/iio-ad799x
   KCONFIG:= \
 	CONFIG_AD799X_RING_BUFFER=y \
 	CONFIG_AD799X
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.16.0)),1)
-  FILES:=$(LINUX_DIR)/drivers/iio/adc/ad799x.ko
-else
-  FILES:=$(LINUX_DIR)/drivers/staging/iio/adc/ad799x.ko
-endif
+  FILES:= \
+	$(LINUX_DIR)/drivers/staging/iio/adc/ad799x.ko@lt3.16 \
+	$(LINUX_DIR)/drivers/iio/adc/ad799x.ko@ge3.16
   AUTOLOAD:=$(call AutoLoad,56,ad799x)
 endef
 
@@ -755,15 +753,11 @@ define KernelPackage/zram
 	CONFIG_ZRAM_DEBUG=n \
 	CONFIG_PGTABLE_MAPPING=n \
 	CONFIG_ZRAM_LZ4_COMPRESS=y
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.14.0)),1)
-  FILES:=\
-	$(LINUX_DIR)/mm/zsmalloc.ko \
-	$(LINUX_DIR)/drivers/block/zram/zram.ko
-else
   FILES:= \
-	$(LINUX_DIR)/drivers/staging/zsmalloc/zsmalloc.ko \
-	$(LINUX_DIR)/drivers/staging/zram/zram.ko
-endif
+	$(LINUX_DIR)/drivers/staging/zsmalloc/zsmalloc.ko@lt3.14 \
+	$(LINUX_DIR)/drivers/staging/zram/zram.ko@lt3.14 \
+	$(LINUX_DIR)/mm/zsmalloc.ko@ge3.14 \
+	$(LINUX_DIR)/drivers/block/zram/zram.ko@ge3.14
   AUTOLOAD:=$(call AutoLoad,20,zsmalloc zram)
 endef
 
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index c86470059e..9dbf06264b 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -16,15 +16,10 @@ define KernelPackage/usb-core
   TITLE:=Support for USB
   DEPENDS:=@USB_SUPPORT
   KCONFIG:=CONFIG_USB CONFIG_XPS_USB_HCD_XILINX=n CONFIG_USB_FHCI_HCD=n
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.16.0)),1)
   FILES:= \
 	$(LINUX_DIR)/drivers/usb/core/usbcore.ko \
-	$(LINUX_DIR)/drivers/usb/common/usb-common.ko
-else
-  FILES:= \
-	$(LINUX_DIR)/drivers/usb/core/usbcore.ko \
-	$(LINUX_DIR)/drivers/usb/usb-common.ko
-endif
+	$(LINUX_DIR)/drivers/usb/usb-common.ko@lt3.16 \
+	$(LINUX_DIR)/drivers/usb/common/usb-common.ko@ge3.16
   AUTOLOAD:=$(call AutoLoad,20,usb-common usbcore,1)
   $(call AddDepends/nls)
 endef