From: Jonas Gorski <jogo@openwrt.org>
Date: Thu, 18 Jul 2013 20:40:15 +0000 (+0000)
Subject: kernel: kmod-gpio-mcp23s08 depends on i2c-core
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=fe1a84ad7133afed1b0c28c728817571436f5b6b;p=openwrt%2Fstaging%2Fansuel.git

kernel: kmod-gpio-mcp23s08 depends on i2c-core

But only if it is selected, so make it a conditionl dependency.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>

SVN-Revision: 37420
---

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 9e97bb566f..f850581ba7 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -135,7 +135,7 @@ $(eval $(call KernelPackage,gpio-dev))
 define KernelPackage/gpio-mcp23s08
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Microchip MCP23xxx I/O expander
-  DEPENDS:=@GPIO_SUPPORT
+  DEPENDS:=@GPIO_SUPPORT +PACKAGE_kmod-i2c-core:kmod-i2c-core
   KCONFIG:=CONFIG_GPIO_MCP23S08
   FILES:=$(LINUX_DIR)/drivers/gpio/gpio-mcp23s08.ko
   AUTOLOAD:=$(call AutoLoad,40,gpio-mcp23s08)