From: Gabor Juhos <juhosg@openwrt.org>
Date: Mon, 11 Mar 2013 21:02:45 +0000 (+0000)
Subject: ramips: add profile and build image for the Upvel UR-326N4G board
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=fe3df4b593d4d203a89781b4632e4a6f9f570734;p=openwrt%2Fstaging%2Fzorun.git

ramips: add profile and build image for the Upvel UR-326N4G board

Patch from: Дмитрий Лебедев <lebedev@trendnet.ru>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 35972
---

diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 67a6f6085e..6ff1bb1bdc 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -633,6 +633,9 @@ define Image/Build/Profile/WR5123GN
 	$(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,wr512-3gn-8M,WR512-3GN,ttyS1,57600,phys)
 endef
 
+define Image/Build/Profile/UPVEL_326
+	$(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,ur-326n4g,UR-326N4G,ttyS1,57600,phys)
+endef
 
 define Image/Build/Profile/UPVEL
 	$(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,ur-336un,UR-336UN,ttyS1,57600,phys)
@@ -673,6 +676,7 @@ define Image/Build/Profile/Default
 	$(call Image/Build/Profile/NBG419N,$(1))
 	$(call Image/Build/Profile/NW718,$(1))
 	$(call Image/Build/Profile/OMNIEMB,$(1))
+	$(call Image/Build/Profile/UPVEL_326,$(1))
 	$(call Image/Build/Profile/PSR680W,$(1))
 	$(call Image/Build/Profile/PWH2004,$(1))
 	$(call Image/Build/Profile/RTG32B1,$(1))
diff --git a/target/linux/ramips/rt305x/profiles/upvel.mk b/target/linux/ramips/rt305x/profiles/upvel.mk
index fa1c9936d7..aff2b94ee0 100644
--- a/target/linux/ramips/rt305x/profiles/upvel.mk
+++ b/target/linux/ramips/rt305x/profiles/upvel.mk
@@ -16,3 +16,15 @@ define Profile/UPVEL/Description
 	Default package set compatible with URVEL router board.
 endef
 $(eval $(call Profile,UPVEL))
+
+define Profile/UPVEL_326
+	NAME:=UPVEL UR-326N4G
+	PACKAGES:=\
+		kmod-usb-core kmod-usb-rt305x-dwc_otg \
+		kmod-ledtrig-usbdev
+endef
+
+define Profile/UPVEL/Description
+	Default package set compatible with URVEL router board.
+endef
+$(eval $(call Profile,UPVEL_326))