From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Date: Tue, 14 Jul 2020 21:32:28 +0000 (-0500)
Subject: pcre: add host variant of libpcre
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=ff02e1561f2073b39814f2d73205a5209471b115;p=openwrt%2Fstaging%2Fxback.git

pcre: add host variant of libpcre

This is needed to build the host variant of libselinux.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---

diff --git a/package/libs/pcre/Makefile b/package/libs/pcre/Makefile
index b638c876da..3655614169 100644
--- a/package/libs/pcre/Makefile
+++ b/package/libs/pcre/Makefile
@@ -61,6 +61,18 @@ define Package/libpcrecpp
   DEPENDS:=+libpcre $(CXX_DEPENDS)
 endef
 
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+	--enable-utf8 \
+	--enable-unicode-properties \
+	--enable-pcre16 \
+	--with-match-limit-recursion=16000 \
+	--enable-cpp
+
+$(eval $(call HostBuild))
+
+
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \