From: John Crispin <john@openwrt.org>
Date: Tue, 29 Mar 2011 06:20:00 +0000 (+0000)
Subject: * fix ARV7518PW support
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=ff885fde8e033399cb797f856f5cc8a993ae8c50;p=openwrt%2Fstaging%2Faparcar.git

* fix ARV7518PW support

SVN-Revision: 26354
---

diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 5fbf332122..bfd73f6dd5 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -119,6 +119,14 @@ define Image/Build/Profile/ARV452CPW
 	$(call Image/Build/$(1),$(1),ARV452CPW)
 endef
 
+define Image/BuildKernel/Profile/ARV7518PW
+	$(call Image/BuildKernel/Template,ARV7518PW,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/ARV7518PW
+	$(call Image/Build/$(1),$(1),ARV7518PW)
+endef
+
 define Image/BuildKernel/Profile/ARV752DPW22
 	$(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
 endef
diff --git a/target/linux/lantiq/patches/400-mach-arv45xx.patch b/target/linux/lantiq/patches/400-mach-arv45xx.patch
index faaa6796f7..4da4c9859b 100644
--- a/target/linux/lantiq/patches/400-mach-arv45xx.patch
+++ b/target/linux/lantiq/patches/400-mach-arv45xx.patch
@@ -38,7 +38,7 @@
 +obj-$(CONFIG_LANTIQ_MACH_ARV45XX) += mach-arv45xx.o
 --- /dev/null
 +++ b/arch/mips/lantiq/xway/mach-arv45xx.c
-@@ -0,0 +1,536 @@
+@@ -0,0 +1,537 @@
 +/*
 + *  This program is free software; you can redistribute it and/or modify it
 + *  under the terms of the GNU General Public License version 2 as published
@@ -524,7 +524,7 @@
 +arv7518pw_init(void)
 +{
 +#define ARV7518PW_EBU			0x2
-+#define ARV7518PW_USB			-1
++#define ARV7518PW_USB			14
 +
 +	lq_register_gpio();
 +	lq_register_gpio_ebu(ARV7518PW_EBU);
@@ -535,6 +535,7 @@
 +	lq_register_nor(&arv75xx_flash_data);
 +	lq_register_pci(&lq_pci_data);
 +	lq_register_wdt();
++	lq_register_tapi();
 +	xway_register_dwc(ARV7518PW_USB);
 +	arv75xx_register_ethernet();
 +	//arv7518_register_ath9k(mac);
diff --git a/target/linux/lantiq/xway/profiles/002-arcadyan.mk b/target/linux/lantiq/xway/profiles/002-arcadyan.mk
index a70a1ef7e1..79694f141e 100644
--- a/target/linux/lantiq/xway/profiles/002-arcadyan.mk
+++ b/target/linux/lantiq/xway/profiles/002-arcadyan.mk
@@ -87,3 +87,15 @@ endef
 
 $(eval $(call Profile,ARV752DPW22))
 
+define Profile/ARV7518PW
+  NAME:=ARV7518PW - ASTORIA
+  PACKAGES:= kmod-usb-core kmod-usb-dwc-otg \
+	kmod-ledtrig-netdev kmod-ledtrig-usbdev kmod-leds-gpio kmod-button-hotplug \
+	kmod-ath9k wpad-mini ltq-dsl-firmware-a swconfig
+endef
+
+define Profile/ARV7518PW/Description
+	Package set optimized for the ARV7518PW
+endef
+
+$(eval $(call Profile,ARV7518PW))